Sage 500 Error 1721 Installer package

Sage Error 1721 comes up when windows Installer package or .Net Framework 3.5.1 is not installed properly on Citrix\Terminal services environment, error indicate such as ".Net Framework 3.5.1 is not found although it is already installed". If want to fix this issue connect us.